Reports of delays when making outbound calls
Incident Report for Close
Resolved
Our carrier has resolved an issue with network performance and calls should be connecting normally.
Posted Mar 09, 2015 - 17:05 PDT
Investigating
Some users are seeing delays between the time they initiate a call and hear ringing and the call connects. We've opened a ticket with our carrier on this.
Posted Mar 09, 2015 - 14:15 PDT