Calling Disruption
Incident Report for Close
Resolved
This incident has been resolved.
Posted Nov 12, 2015 - 13:12 PST
Identified
Our telephony provider, Plivo, is currently experiencing issues which affect Close.io users. We'll keep you posted based on their status updates to https://status.plivo.com
Posted Nov 12, 2015 - 12:38 PST