Issues with renting phone numbers upon signup
Incident Report for Close
Resolved
We have confirmed zero issues with phone renting over the last 11 hours.
Posted Aug 19, 2016 - 00:49 PDT
Monitoring
We have increased our own system's resiliency to the telephony provider's phone renting failures. We will continue monitoring new signups to make sure all of them have a valid phone number.
Posted Aug 18, 2016 - 16:35 PDT
Investigating
Our telephony provider is experiencing issues with phone number search and renting, which can cause issues with calling for new signups. We've communicated the issue to the provider and we're improving the redundancy/resiliency of our own renting module.
Posted Aug 18, 2016 - 12:40 PDT