Application slowdown
Incident Report for Close
Resolved
Response times are back down to normal.
Posted May 04, 2015 - 10:54 PDT
Investigating
We're experiencing high response times across the application and are working to resolve this as quickly as possible.
Posted May 04, 2015 - 10:29 PDT