Calling Disruption
Incident Report for Close.io
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 27, 2017 - 13:16 PDT
Monitoring
Plivo has restored service and we are monitoring the situation.
Posted 3 months ago. Apr 27, 2017 - 11:47 PDT
Investigating
Our telephony provider, Plivo, is currently experiencing issues which affect Close.io users. We'll keep you posted based on their status updates to https://status.plivo.com
Posted 3 months ago. Apr 27, 2017 - 10:07 PDT