Search slowness
Incident Report for Close
Resolved
Our search indexing has remained up-to-date for some time now, but we'll continue to monitor it closely.
Posted Nov 25, 2015 - 10:12 PST
Monitoring
Performance has been restored. Items modified in the last few hours might still take a while until they are updated in search.
Posted Nov 25, 2015 - 02:35 PST
Investigating
Inbox navigation and some of your search queries may experience some slowdowns. We're investigating the cause and fixing it right now.
Posted Nov 25, 2015 - 02:07 PST