Degraded email syncing performance
Incident Report for Close
Resolved
This incident has been resolved.
Posted Nov 19, 2015 - 16:08 PST
Monitoring
All accounts are syncing now. We're still monitoring the situation.
Posted Nov 19, 2015 - 14:55 PST
Identified
You may experience degraded email syncing performance. We're working on bringing it back to normal.
Posted Nov 19, 2015 - 08:59 PST