Issues with accessing close.io application and website
Incident Report for Close.io
Resolved
Amazon has fixed the issues with their CDN. Customers who are still unable to access the close.io application or website should contact support@close.io for further assistance.
Posted 5 months ago. Jun 15, 2017 - 16:17 PDT
Identified
Our provider Amazon is currently experiencing issues with their CDN that may prevent customers from accessing the close.io application or our primary website. We are working with our provider on a resolution to this issue.
Posted 5 months ago. Jun 15, 2017 - 13:53 PDT