Sent emails displaying more than once
Incident Report for Close
Resolved
This incident has been resolved.
Posted Mar 21, 2016 - 09:44 PDT
Identified
We've identified the bug which has been around since March 18 @ 13:00 PT and are in the process of deploying a fix.
Posted Mar 21, 2016 - 08:03 PDT
Investigating
Our processing of sent emails is currently backed up so you may see emails as being sent more than once in the UI or your Sent Items/Message folder within your email account.

**DO NOT WORRY** -- the emails have not been send more than once and this is ONLY A DISPLAY ISSUE.
Posted Mar 21, 2016 - 07:00 PDT