Calling Disruption
Incident Report for Close
Resolved
This incident has been resolved.
Posted Sep 29, 2016 - 15:39 PDT
Investigating
Our telephony provider, Plivo, is currently experiencing issues which affect Close.io users. We'll keep you posted based on their status updates to https://status.plivo.com
Posted Sep 29, 2016 - 14:11 PDT