Upstream carrier issues with inbound calls to some Texas numbers
Incident Report for Close
Resolved
Issue has been resolved by the upstream carriers: https://status.plivo.com/incident/incoming_calls_did/2014/04/24/
Posted Apr 24, 2014 - 14:16 PDT
Investigating
Our provider and their carriers are having issues with some Texas DIDs. For more information and to follow their progress visit https://status.plivo.com/incident/incoming_calls_did/2014/04/24/
Posted Apr 24, 2014 - 10:27 PDT