Application Slowness
Incident Report for Close
Resolved
This incident has been resolved.
Posted Nov 20, 2015 - 14:14 PST
Monitoring
We had some issues with our database servers but have resolved those issues. We're keeping a close eye on everything...
Posted Nov 20, 2015 - 12:22 PST
Investigating
We're investigating a slowdown in application performance. You may experience delays in email syncing, report updates, smartviews / search results, and bulk actions.

The engineering team is currently looking into resolving this as quickly as possible.
Posted Nov 20, 2015 - 11:28 PST