Slowness
Incident Report for Close
Resolved
All has been well for a while now; this incident is resolved. We're very sorry for the issues this morning.
Posted Feb 14, 2014 - 10:32 PST
Monitoring
Site is back up now. Still actively monitoring.
Posted Feb 14, 2014 - 09:39 PST
Investigating
We are currently investigating this issue.
Posted Feb 14, 2014 - 09:17 PST