Some inbox items are not visible
Incident Report for Close
Resolved
All the inbox items should be visible now
Posted Jun 27, 2015 - 21:44 PDT
Identified
We have identified the issue that causes some items to disappear from your inbox. Fix is on the way.
Posted Jun 27, 2015 - 19:05 PDT