Email Syncing Slowdown
Incident Report for Close
Resolved
This incident has been resolved.
Posted Jul 08, 2015 - 14:10 PDT
Identified
Our primary database used for email syncing is experiencing poor performance. We're currently working to add additional capacity.
Posted Jul 08, 2015 - 11:04 PDT