Calls taking longer than expected to connect, sometimes timing out.
Incident Report for Close
Resolved
Our upstream carrier has resolved the issue and continues to monitor for stability.
Posted Jun 16, 2015 - 14:18 PDT
Update
You can follow Plivo's status page here for even faster updates: https://status.plivo.com
Posted Jun 16, 2015 - 10:24 PDT
Investigating
Our upstream carrier, Plivo, is having intermittent issues with outbound calls. We've escalated a ticket to them and will be updating you here with any news.
Posted Jun 16, 2015 - 10:03 PDT