Timeouts when signing up or adding / removing users
Incident Report for Close
Resolved
We have resolved an issue with connectivity to one of our backend databases that caused timeouts when signing up for new accounts or adding/removing users.
Posted Jul 28, 2016 - 12:40 PDT
Investigating
We're investigating reports of timeouts when signing up for new accounts or adding / removing users. The issue seems to be impacting our Billing systems and we're looking into it with urgency.
Posted Jul 28, 2016 - 12:04 PDT