Application Slowness
Incident Report for Close
Postmortem

For approximately 90 minutes users experienced slowness or inconsistent results when performing certain functions such as searches or viewing SmartViews in the Close.io web or desktop apps. This issue was caused by performance degradation in our search backend due to an unexpectedly complex search query.

We are extremely sorry for this downtime and know that you count on Close.io being reliable for your sales needs.

Here's what steps we've taken and will take to help mitigate this issue:

  • We rebalanced our backend search cluster to ensure a more optimal distribution of the workload across all members of the cluster.

  • We are evaluating additional safeguards for search queries as part of a larger ongoing project to improve our search backend.

Posted Nov 28, 2016 - 16:26 PST

Resolved
We have resolved the issues with application performance.
Posted Nov 21, 2016 - 14:49 PST
Monitoring
Things are coming back to full speed now. If you continue to have issues please contact support@close.io. We'll be posting a detailed postmortem once our Dev Ops team has had time to fully investigate what caused this issue.
Posted Nov 21, 2016 - 12:20 PST
Investigating
We're investigating a slowdown in application performance. You may experience delays in email syncing, report updates, smartviews / search results, and bulk actions.

The engineering team is currently looking into resolving this as quickly as possible.
Posted Nov 21, 2016 - 12:04 PST