Issues loading searches and inbox
Incident Report for Close.io
Postmortem

One of the servers for one of our three search clusters experienced connectivity issues due to the underlying Amazon Web Services infrastructure.  In the process of replacing this failing server, a set of invalid connection properties to the search cluster were distributed to the live application which caused all connections to this particular search cluster to fail.  As soon as the error was detected, the connection properties were corrected and we initiated a restart of our application to clear the cache of the bad connection properties.

This was the first time we had replaced one of the servers for this search cluster and we have found that the process used for replacement was insufficient to prevent invalid connection properties from being distributed to the containers running the live Close.io application. We have revised our internal process to include an automatic validation of any modifications to the connection properties before they are implemented in the live application.

Posted 2 months ago. Sep 27, 2018 - 13:54 PDT

Resolved
This issue has been resolved. Please reach out to support@close.io if you have any additional questions.
Posted 2 months ago. Sep 26, 2018 - 10:35 PDT
Investigating
We are receiving reports of issues with loading search queries and inbox in Close.io. We're currently investigating the cause of these issues.
Posted 2 months ago. Sep 26, 2018 - 10:02 PDT
This incident affected: Search (Querying).