Power dialer issues
Incident Report for Close.io
Resolved
This incident has been resolved.
Posted 7 months ago. Mar 14, 2018 - 13:33 PDT
Monitoring
We have deployed a fix for the issues with connecting to the Power Dialer.
Posted 7 months ago. Mar 14, 2018 - 12:52 PDT
Investigating
We are aware of issues using the Power Dialer feature to call leads and are working on a fix.
Posted 7 months ago. Mar 14, 2018 - 12:48 PDT