Search Delays
Incident Report for Close
Resolved
We've identified and resolved the issue. Sorry for the slow down!
Posted Jul 30, 2014 - 10:41 PDT
Investigating
We're investigating a slowdown in our search system that is causing updates/additions/deletes to be slow to appear within the application.
Posted Jul 30, 2014 - 10:35 PDT