Inbound & Outbound Call Service Interruption
Incident Report for Close
Resolved
Plivo has resolved the issues.
Posted Apr 25, 2015 - 02:03 PDT
Investigating
Our carrier, Plivo, is currently experiencing issues with incoming and outgoing calls which affects Close.io users. Follow their updates here: https://status.plivo.com
Posted Apr 24, 2015 - 07:27 PDT