Issues with Inbound & Outbound Calling
Incident Report for Close
Resolved
No further issues with calling have been observed since the issue was resolved.
Posted May 16, 2014 - 23:01 PDT
Monitoring
Plivo has restored calling services. Please let us know if you run into any further issues as we continue to monitor this situation for the next few hours.
Posted May 16, 2014 - 13:12 PDT
Identified
We've identified the issue as an upstream outage with our telephone provider, Plivo. For updates as they resolve this issue you can follow https://status.plivo.com
Posted May 16, 2014 - 12:55 PDT
Investigating
We're currently experiencing issues with inbound and outbound calls and are looking into the cause.

We're very sorry about this inconvenience and will keep you updated as we know more.
Posted May 16, 2014 - 12:47 PDT