Fonts difficult to read in Windows
Incident Report for Close
Resolved
Fonts are working correctly on Windows again.
Posted Aug 21, 2014 - 15:01 PDT
Identified
We've confirmed reports from Windows users of our font being difficult to read today. We've identified this issue as a change in the font hosted by Google, and we're investigating solutions.

See also
https://code.google.com/p/googlefontdirectory/issues/detail?id=331
Posted Aug 21, 2014 - 13:22 PDT