Call initiation delays
Incident Report for Close
Resolved
This incident has been resolved.
Posted Mar 10, 2015 - 13:31 PDT
Monitoring
Our carrier has indicated that they've resolved the issue. If you continue to have issues please let us know as we continue to monitor calls.
Posted Mar 10, 2015 - 09:33 PDT
Identified
Our carrier is currently experiencing delays when initiating outbound calls. This may also result in some inbound calls going directly to voicemail. We've raised a ticket with them and are awaiting resolution.
Posted Mar 10, 2015 - 09:07 PDT