Email syncing issue
Incident Report for Close
Resolved
This incident has been taken care of
Posted Jan 11, 2016 - 18:10 PST
Monitoring
A fix has been pushed, currently monitoring the situation
Posted Jan 11, 2016 - 17:56 PST
Identified
There is an issue with email syncing. The engineering team has already identified and a fix is in the works.
Posted Jan 11, 2016 - 17:35 PST