Slow incoming email processing
Incident Report for Close
Resolved
Inbound email processing times are back to normal.
Posted May 07, 2014 - 12:23 PDT
Investigating
Incoming email processing is currently delayed. We're investigating the root cause and will work to get those messages processed as quickly as possible. Sorry about the inconvenience!
Posted May 07, 2014 - 12:09 PDT