Search slowness
Incident Report for Close
Resolved
This incident has been resolved.
Posted Nov 24, 2015 - 18:35 PST
Investigating
Inbox navigation and some of your search queries may experience some slowdowns. We're investigating the cause and fixing it right now.
Posted Nov 24, 2015 - 14:00 PST