Calling Disruption
Incident Report for Close
Resolved
This incident has been resolved.
Posted Nov 20, 2015 - 05:19 PST
Monitoring
Our telephony provider, Plivo, is currently experiencing issues which affect Close.io users. We'll keep you posted based on their status updates to https://status.plivo.com
Posted Nov 20, 2015 - 04:43 PST