Calling Disruption
Incident Report for Close
Resolved
Plivo has resolved the issue.
Posted Nov 04, 2015 - 16:12 PST
Investigating
Our telephony provider, Plivo, is currently experiencing issues which affect Close.io users. We'll keep you posted based on their status updates to https://status.plivo.com
Posted Nov 04, 2015 - 15:59 PST