Power Dialer connectivity issues
Incident Report for Close.io
Resolved
This incident has been resolved.
Posted 8 months ago. Mar 02, 2018 - 11:31 PST
Identified
Some customers may experience issues with the Power Dialer. Our telephony provider, Twilio, is having connectivity issues and is working to resolve this ASAP. You can follow their status page here: https://status.twilio.com
Posted 8 months ago. Mar 02, 2018 - 08:59 PST